Jump to content

External HardDrive Issue : Urgent!!


Guest Ethan
 Share

Recommended Posts

Guest Ethan

Well , i have a Western Digital 1TB External HardDrive..

It was originally working fine and then i bought a PS3 and converted the HardDrive into FAT32 so it could play on my PS3..

Earlier , It worked fine.. And now i suddenly have these issues...

The HardDrive takes a lot of time to load.. If i copy some file it has speed of 50kbps max..Whereas on other drives i get upto 7-10 mbps..

I have an Intel i5 with a 4GB Ram and 1GB Graphic Card..

I dont really wanna format my HDD as it has 1TB of PS3 Games :)

Any suggestions are welcomed!

Regards,

KD!

Link to comment
Share on other sites

Guest Amb3rsil

Hi - You need to narrow down the issue a bit if possible otherwise you may go through a lot of config problem solving like uninstalling the usb drivers uneccesarily :-

Any chance you can try the disk on another computer?

You experiencing any other issues with other USB devices? Got a pen drive or something you can test with?

Tried just changing the USB cable? Is it particularly long?

A

Link to comment
Share on other sites

Guest Figpucker

This is a bit of a catch-22. On smaller volumes FAT32 usually has faster access times than NTFS, but in this case the opposite is true. There is a long and thorough explanation as to why this is, but basically FAT32 functions in such a way that it searches according to folder size(s), and upon searching for a non-existent file for example, a FAT32 drive must search the entire folder. This is not the case in NTFS drives. Essentially, NTFS makes it so that minimal disk accesses/folder searching is required, thus providing faster speeds on large volumes.

Link to comment
Share on other sites

Guest ings0c

It sounds like it's dying tbh.

If you are tech savvy (even if you're not this is quite easy) then open up the external drive and plug the drive into your pc via sata (or ide) and see if the problem persists.

If the drive is still slow when plugged in directly then it's fucked and you'll probably need a new drive, fixing these kind of issues isn't easy.

If the drive is fast when plugged in, then it's a problem with the caddy. Try a different cable just to eliminate that (i doubt this is the problem). If that doesn't work then buy a new enclosure - they're pretty cheap (at least when compared to an entire new drive).

There's one for £10 here (UK) http://www.scan.co.uk/products/sumvision-aluminium-enclosure-fits-35-sata-ii-3gb-s-hdd-1-x-usb-20-11-black

As for your data, try and drag as much of it as you can off now before the drive completely breaks.

There are companies that specialize in data recovery from failed drives but you're looking at at least a few hundred pounds if you go down that route.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.